Jump to content

Welcome to Geeks to Go - Register now for FREE
Geeks To Go is a helpful hub, where thousands of friendly volunteers serve up answers and support. Get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message and all ads will be removed once you have signed in.
Create an Account Login to Account

Computer doesn't appear in Workgroup


  • Please log in to reply

#1
Diego8

Diego8

    Member

  • Member
  • PipPipPip
  • 189 posts
I have a two computer network connected through cat5 lan. One computer has Win XP Pro SP1, the other has Windows 2000 Server.
In the computer with Win 2000 the workgroup list only shows itself . In the Win XP computer no computer is shown.
I have no idea why this is happening because in the Win XP computer i'm sharing files, the workgroup name is the same in both, i can ping each other. I have ZoneAlarm Pro installed (the network is in Trusted Zone and trusted zone is on Medium level), tryed disabling it but no luck.
Even if the computers were in a different subnet or not connected they should see itself in it's own workgroup list, right?.

Thanks in advance.
  • 0

Advertisement


#2
SpaceCowboy706

SpaceCowboy706

    Trusted Tech

  • Member
  • PipPipPipPip
  • 1,175 posts
Hello Diego8 and welcome to Geeks to Go,

I need a little additional information to ascertain whether or not I will be able to assist you, in correctly setting up your File Share Network.

Please Answer the following questions:

1) What operating System's do you have on all PC's being connected to the File and Print Share network, Please include any Windows Updates or Patches (Example..XP SP1 or 2)?

2) What are the Model and Manufacturer of the Wireless / Wired Adapter's currently Installed on all PC's being Included in this Network?

3) What is the Model and Manufacturer of the Router, Switch, or Hub you are using?

4) What IP Configuration are you using (Example.. DHCP, PPoE / Static, Automatic)

5) What Antivirus programs do you have running?

6) What Firewalls do you have running?

7) What Pop-up Blockers, Ad Blockers, and Malware detectors do you have running?

8) What steps have you already taken to try and implement the File Share for your network?

  • 0

#3
kd1966

kd1966

    Member

  • Member
  • PipPipPip
  • 201 posts
If computers are in a different subnet, then NO, they will not see each other, even if the workgroup name is the same.

Networks are kind of "funny" at times, and even can't see themselves for a variety of reasons. Try the ping command; ping each computer from the other by COMPUTER NAME, then IP ADDRESS............ if this does not work, then ping your ROUTER IP ADDRESS to see if that may be a problem. Also try to ping the computer you are sitting at [127.0.0.0]
  • 0

#4
Diego8

Diego8

    Member

  • Member
  • PipPipPip
  • 189 posts
1) Computer A (the one with the problem) has Windows XP SP1 with all security updates available at Windows Update.
Computer B has Windows 2000 Server. I think this computer doesn't have any updates installed.

2) Computer A: VIA Rhine II Fast Ethernet Adapter. (onborad)
Computer B: VIA PCI 10/100Mb Fast Ethernet Adapter.

3) Computer A has ADSL through the network adapter (PPPoE) but at this moment i don't have installed the switch. I mean, when i want to connect both computers i have to unpulg the ADSL cable and connected the one for the lan.
After the problem with the lan is fixed i will install the switch, which is CONNECTION N&C LS5 10/100 Mbps Nway Switch.
In the switch user's guide it says "SOHO 5/8 ports Ethernet Switch Hub" (mine is 5 ports).

4) Computer A: IP and DNS are assigned automatically. Here is the funny thing, when i go to TCP/IP properties -> Advanced Settings it says "DHCP enabled", but using ipconfig /all it says "DHCP enabled..... no".

Compuer B: IP and DNS are assigned automatically. DHCP is enabled

5) Computer A: Avast! 4.6 Home Edition.
Computer B: None. (This computer is not connected to the Internet)

6) Computer A: ZoneAlarm Pro version 6.0.667.000
Computer B: None.

7) Computer A: Lavasoft Ad-Aware SE Professional Build 1.06r1.
Computer B: None.

8) At first in Computer A when i tryed to share a folder it said "Windows has disabled remote access to this computer.... run Network Setup Wizard". I did ran it a few times but i at the end of the wizard it always said that an error ocurred trying to configure the Network. Then i realised that the Network adapter drivers were the one from Windows database, so i install the drivers that came with the motherboard. This time the error window didn't show up but i still couldn't see any computer in the workgroup.
I tryed disabled simple file sharing and also setting TCP/IP over NetBios to enabled (before that it was in default) but no luck.
One thing that caught my attention was that TCP/IP over NetBios was enabled but the ipconfig /all command says "TCP/IP over NetBios......disabled".
Tryed to ping each other and it works fine.
Tryed to search for computer A being sitted in front of compuer A and it was found. I opened it and all the shared folders showed up then i tryed to open any folder and an error windows opened saying "You don't have access to \\computer_name\folder_name. You might not have permission to use this network resource. Contact the administrator.... .
Unable to access the network location".
Funny thing becuase i have administrative rights.
I have also tryed to set IP manually in both computers. Computer A using IP 192.168.0.1 and B 192.168.0.2 but it didn't work.

A few months ago the network was working just fine then i had to re install Windows XP (it was the same version as now) so it should be some misconfiguration.

Thanks in advance.
  • 0

#5
Diego8

Diego8

    Member

  • Member
  • PipPipPip
  • 189 posts
I tryed to ping using computer name but it didn't work, i can only ping by name the computer i'm sitting at. Ping by IP works. At this moment i'm not using a router or switch.
I think you ment 127.0.0.1 insted of 127.0.0.0, ok i tryed to ping localhost (127.0.0.1) and it works.

Thanks in advance
  • 0

#6
SpaceCowboy706

SpaceCowboy706

    Trusted Tech

  • Member
  • PipPipPipPip
  • 1,175 posts
Diego8,

Please Follow Process's 1 and 2 to complete the Network Setup Wizard Correctly and also to temporarily disable all active processes for troubleshooting purposes.

PROCESS 1 - Complete the Network Setup Wizard with your switch connected:


1. Double click My Computer icon
2. Under "Other Places" on the left Pane select the "My Network Places" link
3. Under "Network Tasks" select the "Set up a home or small office network" link
4. When the Network setup wizard appears click "Next"
5. When the second page appears click "Next"
6. When the third Page appears select the "Other" bubble and click "Next"
7. When the fourth page appears select the bubble "This computer connects directly or through a network Hub. Other computer on my network also connect to the internet directly or through a hub."
8. When the fifth page appears under "Computer description" type in XP PRO, Computer name XP PRO and click "next"
9. When the sixth Page appears under "workgroupe name" type in: namegroup - insert your last name in the namegroup and click "next"
10. When the seventh page appears select the "Turn on File and Print Sharing" Bubble and click "next".
11. When the warning comes up asking if your sure you want to turn on file and print sharing just select "yes".
*NOTE* If you do not want to create a self install disk for additional PC's skip the following steps and proceed to Step 11a through 11c at the end of this page.
12. When the seveth page appears click "Next".
13. When the eigth page appears under "What do you want to Do?" Select the "Create a Network Setup Disk" bubble and click "next".
14. When the ninth page appears select the "Format Disk" Button
15. When the format 3 1/2 Floppy (A:) screen appears just click "start"
*NOTE* If you get a warning that says formatting will erase all data - this means it will erase all data on the floppy disc - not on your hard drive
16. When it is done select "ok" then hit the "x" to close out the format screen... this takes you back to page nine and select "next".
17. Now you will a screen that shows files being copied... just wait till its done and you will be automatically sent to screen 10. Just click on "next".
18. When the eleventh page appears just click "finish".
19. Now restart your machine
20. Now go to the next computer and complete the Following

Additional Pc Setup
21. Insert the disk in the A drive
22. Double click the "my computer" icon
23. Select open network setup disk
24. double click "netsetup"
25. If the PC is unable to read the disk then just repeat steps 1-11 and include the following steps after steps 1-11 have been completed:


11a. When the next page appears select the bubble for "Just finish the wizard" and click on "Next"
11b. When the next screen appears just select "Finish"
11c. Now reboot your PC

-------------ONLY AFTER ALL THESE STEPS HAVE BEEN COMPLETED-------------
----------------------------MOVE ON TO PROCESS 2 --------------------------------

PROCESS 2 - View worgroup and Disable Protocol Blockers, with your switch connected.

1. Go back to the first computer and double click on the "my computer" icon
2. Under "Other Places" on the left Pane select the "My Network Places" link
3. Under "Network Tasks" on the left pane select the "View workgroup computers"
4. After clicking on this you will get a list of all the computers in your network. If the additional computers you added are not showing up then disable all Virus Scanners, Ad Blockers, Firewalls, And Security Suites..
5. Go back to the first computer and double click on the "my computer" icon
6. Under "Other Places" on the left Pane select the "My Network Places" link
7. Under "Network Tasks" on the left pane select the "View workgroup computers"
8. After clicking on this you will get a list of all the computers in your network. If the additional computers you added are not showing up then we must GURANTEE that you have shut down all protocol blockers by disabling them through the microsoft configuration tool. Follow these steps to accomplish this:


TO BE DONE ON ALL PC'S ON THE NETWORK - Disabling all active processes for Selective startup troubleshooting:

1. Click on START
2. Click on RUN
3. Type in... msconfig
4. when the System Configuration Utility appears click on the SERVICES tab
5. Check the HIDE ALL MICROSOFT SERVICES box
6. Copy down which boxes have a check in them so you can them restore back later
7. Click on the DISABLE ALL Button
8. Click on the STARTUP Tab
9. Copy down which boxes have a check in them so you can them restore back later
10. Click on the DISABLE ALL Button
11. Click on the APPLY Button
12. Click on the OK Button
13. Click on the RESTART Button
14. When the PC restarts check the Selective startup notification box and click on the OK button
*NOTE* Perform steps 1-14 of this process for the other computer before mpving on to the rest of the steps.
15. Go back to the first computer and double click on the "my computer" icon
16. Under "Other Places" on the left Pane select the "My Network Places" link
17. Under "Network Tasks" on the left pane select the "View workgroup computers"
18. After clicking on this you will get a list of all the computers in your network. If the additional computers you added are finally showing up then we have verified that a third party program is blocking your share ability. to find out which program it is just simply run the Msconfig again and under the Services and Startup tab... turn the components you unchecked back on one by one until you lose your share ability. If you are still not able to Share then Post back and we will continue with more advanced procedures.

  • 0

#7
Diego8

Diego8

    Member

  • Member
  • PipPipPip
  • 189 posts
First of all, thank you for posting those step by setp procedures.

Well, i did all that but i still can't see any computer in "View workgroup computers".
Also, some steps you mentioned were not shown in my network wizard.
In Process 1:
Between step 7 and 8 the wizard shows a list of all connections available in my computer.
This is what it says:
Select your Internet connection from the list

ADSL WAN miniport (PPPOE)
Local Area Network VIA Rhine II Fast Ethernet Adapter.

So, i chosed ADSL and then click Next. Then setp 8 window appears.
Also setp 10 window is not shown, instead a window sumarizing all the settings i applied appears. Click next and then it stats applying those settings.
I had to run the wizard two times because the first time it displayed an error while it was applying settings. The window said : "Cannot complete the network wizard.
An error has ocurred during configuration of the network on this computer.
You can configure the network manually, or you can run the wizard again with different settings".

I ran the wizard again and no error window was shown. Rebooted my pc but still couldn't see any computer.
Then deactivated all virus scanners, Ad Blockers and firewalls but nothing changed.

Finally i run the msconfig tool. Deactivated all none microsoft serivces, disabled all startup applications then click on the apply button and a window came up. It said "An access denied error was returned while trying to change a service. Log on as administrator to change settings" (i had to translate it. My apologies if it's not well written), funny thing becuase i have administrative rights. Also i couldn't identify which service couldn't be disabled because they were all unchecked.
Finally tryed to run msconfig in the other computer but it seems that this tool is not availabe on Windows 2000 Server.It says that the file was not found.
Rebooted but still the same problem.

I really have no idea what's not working.

Thanks in advance.

Edited by Diego8, 13 November 2005 - 09:19 AM.

  • 0

#8
SpaceCowboy706

SpaceCowboy706

    Trusted Tech

  • Member
  • PipPipPipPip
  • 1,175 posts
Diego8,

Reboot the problematic PC into Safe mode,: "An access denied error was returned while trying to change a service. Log on as administrator to change setting" as follows:

PART 1
1. START
2. TURN OFF COMPUTER
3. RESTART
4. As the machine starts to reboot start pressing the F8 key until you come to the selective startup screen that offers the Safe mode startup option. Select SAFE MODE from the list and hit ENTER.
5. If you get a screen that asks for user log on please select the administrator user.
6. Repeat the steps for Part 2, to clear all startup items:


PART 2
1. Click on START
2. Click on RUN
3. Type in... msconfig
4. when the System Configuration Utility appears click on the SERVICES tab
5. Check the HIDE ALL MICROSOFT SERVICES box
6. Copy down which boxes have a check in them so you can them restore back later
7. Click on the DISABLE ALL Button
8. Click on the STARTUP Tab
9. Copy down which boxes have a check in them so you can them restore back later
10. Click on the DISABLE ALL Button
11. Click on the APPLY Button
12. Click on the OK Button
13. Click on the RESTART Button
14. When the PC restarts check the Selective startup notification box and click on the OK button
*NOTE* Perform steps 1-14 of this process for the other computer before mpving on to the rest of the steps.
15. Go back to the first computer and double click on the "my computer" icon
16. Under "Other Places" on the left Pane select the "My Network Places" link
17. Under "Network Tasks" on the left pane select the "View workgroup computers"
18. After clicking on this you will get a list of all the computers in your network. If the additional computers you added are finally showing up then we have verified that a third party program is blocking your share ability. to find out which program it is just simply run the Msconfig again and under the Services and Startup tab... turn the components you unchecked back on one by one until you lose your share ability. If you are still not able to Share then Post back and we will continue with more advanced procedures.

  • 0

#9
ong2lua

ong2lua

    Member

  • Member
  • PipPip
  • 53 posts
Please make sure that you turn off all the Windows Internet Connecton Firewalls on both computers as well.
  • 0

#10
Diego8

Diego8

    Member

  • Member
  • PipPipPip
  • 189 posts
SpaceCowboy706, thanks for the handy tip of booting into safe mode and using the default administrator account.
Well, this time no error window came up but things are the same, i mean, the computers list is still empty.
I guess the problem is more serious than i thought.

Thanks in advance.
  • 0
<

Advertisement


#11
Diego8

Diego8

    Member

  • Member
  • PipPipPip
  • 189 posts
ong2lua, My Windows version is XP Pro SP1 so i don't have the Windows firewall. My firewall is ZoneAlarm Pro, i tryed disabling it but that didn't work out.
I also checked if the Internet Connection Firewall was enable on my local area network connection but it isn't.

Thanks.
  • 0

#12
ong2lua

ong2lua

    Member

  • Member
  • PipPip
  • 53 posts
I had experienced a similar problem, but then i uninstalled Norton Internet Security and restarted the computer. Then all a sudden, it worked. You might want to try uninstall ZoneAlarm Pro, just for testing purposes.

PS: Disabling Norton internet Security wasn't enough to make it work on my computers.

Edited by ong2lua, 14 November 2005 - 10:13 PM.

  • 0

#13
SpaceCowboy706

SpaceCowboy706

    Trusted Tech

  • Member
  • PipPipPipPip
  • 1,175 posts
By completing the network setup wizard we have already configured the windows firewall for File share, so we know that, that firewall is not an issue.

By booting into safe mode then running msconfig and shutting down all non microsoft programs we have eliminated any other security suite, third party firewall or virus scanner as being the cause.

With our inability to still, not share files, the only other problem blocking our share ability would have to be a fault in the Operating system itself, or incorrect setup in the network. The only other thing I can reccomend from here would be to either:


1. Uninstall your TCP/IP stack, Then Use the Windows Repair Utility, Then re-install your TCP/IP stack and run the network setup wizard again. (Making sure to leave all non MS Programs turned off from safe mode)

2. Reinstall windows ( LAST DITCHED IDEA WHEN EVERYTHING ELSE FAILS AND THERE IS NO ALTERNATIVE, AND THE SKY IS BURNING AND THE WILDLIFE HAS DISSAPPEARED)

3.Have SpaceCowboy706 seek help from one of the Elder SUPERMEN located here at Geeks to Go..... Already in process......

  • 0

#14
brianmil0923

brianmil0923

    Member

  • Member
  • PipPipPip
  • 191 posts

I have a two computer network connected through cat5 lan. One computer has Win XP Pro SP1, the other has Windows 2000 Server.


Hey Diego8,
That may be your first problem. Peer-to-peer networking (workgroup) isn't going to work that well, when you have a client-server setup. You need to start thinking in terms of domain not workgroup. On the 2000 server, create the domain, and add the xp client to the domain. Meaning the xp machine will have to log onto the domain you create on the server.

Let me know how this goes or if you have any trouble creating a domain!

Edited by brianmil0923, 15 November 2005 - 09:57 PM.

  • 0

#15
nikki22

nikki22

    Member

  • Member
  • PipPip
  • 14 posts
had you checked your workgroup name?

like all the computer are in a group called (YOUTHECH)

did you also try changing your ping name?

did you try ping...

hahaha

not realy helpful isn't it.....


just trying to help

Nicolas.
  • 0

Advertisement



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

featured