Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Error 47 - USB device not recognized


  • Please log in to reply

#1
jroope

jroope

    New Member

  • Member
  • Pip
  • 8 posts
I just bought a new computer. When I try to hook up the external Maxtor 3100 USB HD (which I have used for over a year), I get an error indicating the "USB device not recognized". When I pursue this in Troubleshooter/Device Manager, I get this message:

Windows cannot use this hardware device because it has been prepared for "safe removal", but it has not been removed from the computer. (Code 47) To fix this problem, unplug this device from your computer and then plug it in again.


Unplugging and reconnecting as advised does not help, nor does rebooting. The drive works fine on my laptop.

I have tried attaching the drive to my laptop and ejecting it both with and without using the safe removal tool - no luck. Either way it continues to work on the laptop but not on the new desktop.

I have removed items in startup that would be likely culprits to conflict (best guess) - no luck

Help :tazz:
  • 0

Advertisements


#2
The Skeptic

The Skeptic

    Trusted Tech

  • Technician
  • 4,075 posts
Have you tried another usb device on this computer?
have you tried connecting the Maxtor to another usb port?
Have you checked in Device Manager that usb drivers are installed?

If after this you still have the problem I would do two things:

1: Enable every item in BIOS which is related to usb.
2: reinstall usb drivers using the drivers disk which you should have gotten with the new computer.
  • 0

#3
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
hook it up to your laptop...then eject the device the right way (doing the safely remove device doohickey)...then turn off the drive...it should have a power button....then plug the device into the other computer...and turn the power switch on
  • 0

#4
jroope

jroope

    New Member

  • Topic Starter
  • Member
  • Pip
  • 8 posts

hook it up to your laptop...then eject the device the right way (doing the safely remove device doohickey)...then turn off the drive...it should have a power button....then plug the device into the other computer...and turn the power switch on



Thanks for the reply - I had done that, tried it yet again - no luck :tazz:
  • 0

#5
dsenette

dsenette

    Je suis Napoléon!

  • Administrator
  • 26,019 posts
  • MVP
the new computer is xp right? and the laptop is 98?
  • 0

#6
jroope

jroope

    New Member

  • Topic Starter
  • Member
  • Pip
  • 8 posts

Have you tried another usb device on this computer?
have you tried connecting the Maxtor to another usb port?
Have you checked in Device Manager that usb drivers are installed?

If after this you still have the problem I would do two things:

1: Enable every item in BIOS which is related to usb.
2: reinstall usb drivers using the drivers disk which you should have gotten with the new computer.


All other USB devices work fine on the desktop machine...

Tried all my ports... same result

Device Manager says USB drivers are fine, although it sees the Maxtor as an "Unknown device" and therefor reflects no driver...

No Install disk with the computer - it has a "Restore" special partition wipes out everything if I activate it...

I'll try the BIOS thing

Thanks for the help so far!
  • 0

#7
jroope

jroope

    New Member

  • Topic Starter
  • Member
  • Pip
  • 8 posts

the new computer is xp right? and the laptop is 98?



Both XP - I have run all the updates
  • 0

#8
jroope

jroope

    New Member

  • Topic Starter
  • Member
  • Pip
  • 8 posts

Have you tried another usb device on this computer?
have you tried connecting the Maxtor to another usb port?
Have you checked in Device Manager that usb drivers are installed?

If after this you still have the problem I would do two things:

1: Enable every item in BIOS which is related to usb.
2: reinstall usb drivers using the drivers disk which you should have gotten with the new computer.


Hi again...

I plugged into an external USB hub with a USB 1.1 port - viola! It worked

Soooooooooo .........

How do I install my USB 2 drivers again when I don't have a disk? All my native ports are USB 2

I did enable USB legacy in the BIOS... (it had been set to "Auto" - changed it to "Enabled")
  • 0

#9
The Skeptic

The Skeptic

    Trusted Tech

  • Technician
  • 4,075 posts
The whole thing is quite strange. First, If your Maxtor is designed to work under usb 2.0 it should also work under usb 1.1. second, are you sure that your computer can support usb 2.0? To identify whether you have usb 2.0 drivers installed click control panel > system > device manager and look at usb drivers to see if any carries the title "usb enhanced controller". If none carries this title then your computer runs only usb 1.1.

Your computer must be quite old if you run it on win 98SE and there is a question if it can run usb 2.0. Try to find out at the motherboard manufacturer internet site. This is also the place to look for a driver.

If the computer cannot support usb2.0 you can overcome this problem by installing a usb 2.0 pci card. These usually carry some 4 ports, they are very useful and rather cheap.
  • 0

#10
jroope

jroope

    New Member

  • Topic Starter
  • Member
  • Pip
  • 8 posts

The whole thing is quite strange. First, If your Maxtor is designed to work under usb 2.0 it should also work under usb 1.1. second, are you sure that your computer can support usb 2.0? To identify whether you have usb 2.0 drivers installed click control panel > system > device manager and look at usb drivers to see if any carries the title "usb enhanced controller". If none carries this title then your computer runs only usb 1.1.

Your computer must be quite old if you run it on win 98SE and there is a question if it can run usb 2.0. Try to find out at the motherboard manufacturer internet site. This is also the place to look for a driver.

If the computer cannot support usb2.0 you can overcome this problem by installing a usb 2.0 pci card. These usually carry some 4 ports, they are very useful and rather cheap.



I appreciate the help... track back through the other posts more carefully...

All my USB ports show as Enhanced (USB2) in device manager. The computer was purchased new on Friday.
Both my desktop machine and my laptop run XP Home (another poster was guessing earlier that the laptop ran 98 SE)

I discovered that my external USB 2 hub has one port (of five) that will recognize the drive just fine, while giving a brief warning that the drive would perform faster if plugged into a USB2 port. If I click that warning bubble it shows me a list of USB2 ports available on my computer (in essence all my unused ports)

Perplexing - ain't it :tazz:

Thanks again - Jroope
  • 0

#11
The Skeptic

The Skeptic

    Trusted Tech

  • Technician
  • 4,075 posts
Sorry about my mistakes. the truth is that I didn't re-read the thread from the beginning. I just saw that you run 98SE (in addition to XP, that's what you wrote in your profile) and from that I deduced a number of logical assumptions for a nonexistent computer.

The note that you get: "..... giving a brief warning that the drive would perform faster if plugged into a USB2 port" is typical for a usb 2.0 device that is connected to a usb 1.1 port.

Your USB driver, were it installed by the XP or through your drivers disk which you should have gotten with your new computer? Try reinstalling the driver with the aid of the disk or even better, download it from the motherboard manufacturer site. I would delete all the existing controllers and install them afresh.
  • 0

#12
jroope

jroope

    New Member

  • Topic Starter
  • Member
  • Pip
  • 8 posts

Sorry about my mistakes. the truth is that I didn't re-read the thread from the beginning. I just saw that you run 98SE (in addition to XP, that's what you wrote in your profile) and from that I deduced a number of logical assumptions for a nonexistent computer.

The note that you get: "..... giving a brief warning that the drive would perform faster if plugged into a USB2 port" is typical for a usb 2.0 device that is connected to a usb 1.1 port.

Your USB driver, were it installed by the XP or through your drivers disk which you should have gotten with your new computer? Try reinstalling the driver with the aid of the disk or even better, download it from the motherboard manufacturer site. I would delete all the existing controllers and install them afresh.


Ahhh - there's the rub - the driver disk I SHOULD have gotten... This computer came with a special partition for RESTORE operations, but no disk! I can restore the whole shebang to state of purchase or I'm on my own...

The driver is installed by XP. I'll try to locate the MB manufacturer and do as you suggest.

I recognized the warning as an indicator that the port on the external hub is being seen as a 1.1 port.

Thanks!
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP