Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Firefox can't load Javascript


  • Please log in to reply

#1
criticman

criticman

    Member

  • Member
  • PipPip
  • 37 posts
I'm running Windows 2000 SP4 on Gateway PIII 450 with 128MB of RAM and a 32MB nVidia TNT Vanta 64 video card.
I'm using Firefox, I just installed the latest version on this machine. sites visited on this browser are telling me that I don't have Javascript enabled or cookies allowed. Neither is true. I've checked repeatedly, and all to no avail. As I'm sure you're aware, Forefox's support is non-existent so I'm on my own here. I'd appreciate any help.
Incidentally, I'm well-protected against spyware and viruses and am not have any problems in that regard. Also, IE plays the same sites that complain about Javascript and cookies, without a hitch.
  • 0

Advertisements


#2
makai

makai

    Portlock - Oahu

  • Member
  • PipPipPipPipPip
  • 2,793 posts

As I'm sure you're aware, Forefox's support is non-existent

Well, not exactly true. Their forums are well populated with many people willing to help. I do visit there once in a while and have witnessed quite a few people trying to help out.

But... anyways... back to your problem.

Can you connect to any sites at all using FF? Or are only certain sites not accessible?

Edited by makai, 09 December 2005 - 08:27 AM.

  • 0

#3
criticman

criticman

    Member

  • Topic Starter
  • Member
  • PipPip
  • 37 posts
Firefox works as it should, except for the problems I mentioned. I've been having to login on many sites where I didn't have to before, such as Yahoo mail and this site. I'm assuming this is a Javascript thing.
  • 0

#4
makai

makai

    Portlock - Oahu

  • Member
  • PipPipPipPipPip
  • 2,793 posts
This sounds like more a problem of your brower deleting your cookies. FF has the option of retaining cookies, rather exempting certain cookies, from deletion when you clear out FF cache, and history.

If you go to FF Tools/options/privacy/cookies, there should be an "Exception" button you can press and enter the websites that you want FF to retain cookies for... regardless if you empty all your FF trash. Once you do this, you should be able to enter yahoo mail and not have to login all the time. Of course, you must log in at least once, and enter the site address into FF exception box.
  • 0

#5
criticman

criticman

    Member

  • Topic Starter
  • Member
  • PipPip
  • 37 posts
I'm allowing anyone and everyone to set cookies in this browser. Javascript, according to settings, is also alive and well. All that information seems to be faulty.
  • 0

#6
makai

makai

    Portlock - Oahu

  • Member
  • PipPipPipPipPip
  • 2,793 posts
Have you tried using the Exception option for allowing site cookies?

Here's what you need to do.

Go to the website you wish to always stay logged into and copy the address (highlight + ctrl+c)

Now go up to the menu and open Tool/Options/Privacy/Cookies/Exceptions

Now paste (ctrl+v) the website address you just copied into the "Address of Website box"

Right below the "Address of Website box", click on the Allow button then close the Exceptions window, then close the Options window by clicking on OK.

This procedure tells FF to allow and save cookie information for the site you just provided.

You will have to do this for every site you wish to work this way.
Note also that if you have just opened your browser and visit another area of this site that has a different address that you have "not" entered into the Exception box, you will have to log in. In other words, this procedure is strict and address sensitive!

You must also set FF options not to delete cookies at shutdown and also not until they expire.

Last note... this will not work for every single site... but it sure works for this one!

Edited by makai, 10 December 2005 - 01:21 AM.

  • 0

#7
criticman

criticman

    Member

  • Topic Starter
  • Member
  • PipPip
  • 37 posts
I'm allowing everybody to set cookies. What would be the point of excepting all then adding sites I would allow? That would seem to be beside the point, wouldn't it? FF should do what it's supposed to do. On my other computer (faster but exact same options) I've not had this problem.

Okay. I set FF to not accept cookies from ANYONE. The outcome of that was that all of the sites that were previously letting me in are now telling me to allow cookies, as well as the sites that wouldn't llow me in.
So. This is a Javascript problem, not a cookie problem. The cookie error messaes are riding piggyback on the Javascript error messages.
I've reset FF to accept all cookies.
What now? According to FF, Javascript is alive, well and enabled. Apparently this isn't so.

Edited by criticman, 11 December 2005 - 01:28 PM.

  • 0

#8
criticman

criticman

    Member

  • Topic Starter
  • Member
  • PipPip
  • 37 posts
Okay. Problem has been solved. I downloaded one of FF's highly touted extensions called 'No Script", it runs covertly and it's purpose mainly, is to eliminate activeX interference (and give you options for whether to load Flash files and such). What it never said when i downloaded it, was that the default setting for javascript is "off". The only sign of the extension is a small blue "S" on the bottom bar. That is ALL. If you don't know what it is, you can easily overlook it. Over the weekend I downloaded an updated Venkman debugger, which only partially fixed the problem. I just now spotted the "S" with a red circle with a line through it on top. That was the key. I mention this on the off chance you ever run across a similar problem. Thanks for the help.
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP