Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Scanner Twain problems


  • Please log in to reply

#106
coachwife6

coachwife6

    SuperStar

  • Retired Staff
  • 11,413 posts
I notified Jack123 that you are good to go. Good luck. :tazz:
  • 0

Advertisements


#107
Ardent

Ardent

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 153 posts
Thank you for all the assistance!
  • 0

#108
Jack123

Jack123

    Trusted Tech

  • Retired Staff
  • 944 posts
Removing Double Post -???

Edited by Jack123, 18 January 2006 - 11:22 AM.

  • 0

#109
Jack123

Jack123

    Trusted Tech

  • Retired Staff
  • 944 posts
Scanner Twain Problem (PMW-1)
18th Jan 2006

Hello – Coachwife6 sent me a PM – that you are cleared –

I notified Jack123 that you are good to go. Good luck.


I have run every conceivable scan that I know of. I think he is clean.


Ok – Looks like this – [Thread] – is where we will pick up your – [Hardware Issues] - I think we should begin with you reviewing your PC – And List your Hardware Issues – I am sure that things have changed –

Please fill out your Hardware Issues, using attached Form –and Attach – on [Return Post] –
*******************SEE ATTACHMENT******************

This is still your Dell Laptop – and you still have [Everest] Installed –

Is [Device Manager] Issue taken care of – thru – [Malware Removal]

Have a good day -
Jack123

Attached File  Hardware_Issue_Review_List.doc   51.5KB   31 downloads

Edited by Jack123, 18 January 2006 - 11:23 AM.

  • 0

#110
coachwife6

coachwife6

    SuperStar

  • Retired Staff
  • 11,413 posts

Is [Device Manager] Issue taken care of – thru – [Malware Removal]


Yes, Jack. We did the appropos rootkit fix several times and it was clean. You might have Swandog look at the last few posts if you want to make sure. I believe he wrote the program. :tazz:
  • 0

#111
Ardent

Ardent

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 153 posts
Hello and thanks for the assitance

I have a Dell 8250 Desk top pc. I do not have Everest installed, maybe some confusion there. My device manager issue is not solved, I still don't have devices listed. I can see them when I am in safe mode. The basic issue is my Epson 1670 scanner, which does not work. It gives me a message ...scanner not ready or its busy or another device is using it . So while it maybe clean of viruses I am afraid the original issue still exists and has not been affected by the cleaning programs I have done.
  • 0

#112
Jack123

Jack123

    Trusted Tech

  • Retired Staff
  • 944 posts
Scanner Twain Problem (PMW-#2)
19th Jan 2006

Item –1 [Everest Installation] -

I do not have Everest installed, maybe some confusion there.


In my 3rd Post to you Post #51 I requested you to download – [Everest] –

I need you to Download this FREE – Home Edition of [Everest] – From this Website - http://www.filehippo...d_everest_home/


Then in my 4th Post – Post #55 I gave you this [Attachment] - 01_EVEREST_3F_Attatchment.doc ( 32k ) Number of downloads: 2
That had instructions –[How to make Reports & Attach them] There were 2 downloads & I have [3 Everest Reports] – See below from your Post - Post #56 [See Below]

Here are the reports I haven't done the msconfig suggestion yet. I will and get that info back to you in just a minute.


Attached File(s)
Report1.htm ( 155.79k ) Number of downloads: 2
ReportDevices.htm ( 60.38k ) Number of downloads: 1
Reportmother.htm ( 54.91k ) Number of downloads: 1
___________________________________________________________________

Item 2 – [Device Manager Issue]

My device manager issue is not solved, I still don't have devices listed. I can see them when I am in safe mode.


Ok – We will work in – [Safe Mode] – As a work-around – for now – I will do some research on this
____________________________________________________________________

Item 3 – [Epson 1670 scanner]

The basic issue is my Epson 1670 scanner, which does not work. It gives me a message ...scanner not ready or its busy or another device is using it . So while it maybe clean of viruses I am afraid the original issue still exists and has not been affected by the cleaning programs I have done.


I – 1st reviewed your [Original Post] on this [Thread] – 29th December 2006 & made the determination that your PC was possibly [Malware Infected] – And requested – [Malware Tech Aid] –

This is this [Forum’s Policy] – Suspect Malware – Contact Moderator to – Send Poster to – [Malware Forum] –
Purging Malware & Malware Protection are [Primary Function] 0f G2G Forum – Everything else is – Secondary

So [Primary Job] was performed – by the [A-Team] – Now is the time for – [B-Team] –

In my – 1st Post Post #47 I gave you 2 utilities for [Device Manager] – to aid with Troubleshooting – Did you do both of them – If not – Do them now –

In my 3rd Post Post #51 - I gave you several links pertaining to your Scanner – Have you looked at them -

Epson 1670 Scanner Links -

(1)-Product Information-
http://www.epson.com...tegory=Products

(2)-Support
http://www.epson.com...rodoid=35836299

(3)-Documents & Manuals
http://www.epson.com...rodoid=35836299

________________________________________________________________

Ok – I will crawl back into the [Coal Mines] – And review

1- This Thread
2- [Everest Reports]
3- Research Scanner details]
4- Research [Device Manager Issue]
5- Then formulate a Detailed Plan

In the meantime – You can look at my – [Referenced Posts] and get your PC ready/prepared – And – Look at [Device Manager] – In [Safe Mode] – and give a report on all Scanner Instances –

1-Present Scanner Activity
2-Unknown Devices
3-Other Devices
4-Problem Devices
5-Non Present Devices

Then think back – How long have you had Scanner installed – In This Laptop – And what were you doing prior to encountering problem –

I have an epson 1670 scanner hooked up to windows xp on my pc. Last week while trying to scan a picture I got a message saying
" scan could not be started could not open twain source make sure it is a vaild source for the scanner.
I have never had any problems with this scanner in the 2 years I've owned it. I tried opening it from its software interface and got a message
"unable to start the scanner because it is not ready or another application is using it"
The scanner is ready and I can't think of any other programs that is using it. There might have been a problem with a trojan virus I downloaded 3 weeks ago. I discovered it and had to purchase and install Doctor spyware to remove it. It removed it but I seem to recall some kind of twain source message that flashed accross my screen at the time. Is there a connection? A friend said to go to device manager and uninstall the drivers, then go to windodws twain directory folder and delete its contents.I went to device manager in the control panel and open the folder but it was blank, no scanner nothing just a blank folder. This got me thinking that it might be more than just a simple problem. any suggestion for the next step would be greatly appreciated.


Yes it is completely empty,... nothing but I did go into safe mode and all the drivers appeared. I found the drivers for the epson scanner, there was also another driver there for a camera that i don't own and I am not sure what it was. I disabled it thinking this migh be a conflict. I was getting a message saying that the scanner "action could not be completed because the other program is busy choose switch to to activate the busy program and correct the problem" I tried the scanner again but no luck do I have to do a hard reboot before the disable works?


Tell me more about camera driver –
_____________________________________________________________

Leave me play in the – [Coal Dust] –
And I will get back to/with you whenever I crawl out -
Jack123

Edited by Jack123, 19 January 2006 - 02:43 AM.

  • 0

#113
Ardent

Ardent

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 153 posts
I went through your posts and I think I did just about everything you suggested. I am not sure about Everest but I will try it again.
As for the camera driver...well I'm not sure it could be the video camera that I see in my program list , but I don't have a video camera attached to my pc, or it could be sosmething for my Canon A95 camera, some kind of interface. I really don't hook up my camera to the pc . I will go over your logs and see what additional information I can provide.

Thanks
  • 0

#114
Jack123

Jack123

    Trusted Tech

  • Retired Staff
  • 944 posts
Scanner Twain Problem (PMW-#3)
19th Jan 2006

My last Post –(PMW-#2) – was meant to be – A [Review/Summary] – to bring everybody up to date on the – {Hardware Issues] – It is not just you that I am helping – We have over 1100 viewers – looking On -

I went through your posts and I think I did just about everything you suggested. I am not sure about Everest but I will try it again.
As for the camera driver...well I'm not sure it could be the video camera that I see in my program list , but I don't have a video camera attached to my pc, or it could be sosmething for my Canon A95 camera, some kind of interface. I really don't hook up my camera to the pc . I will go over your logs and see what additional information I can provide


I gave you some research to do –

In the meantime – You can look at my – [Referenced Posts] and get your PC ready/prepared – And – Look at [Device Manager] – In [Safe Mode] – and give a report on all Scanner Instances –

1-Present Scanner Activity
2-Unknown Devices
3-Other Devices
4-Problem Devices
5-Non Present Devices

Then think back – How long have you had Scanner installed – In This Laptop – And what were you doing prior to encountering problem –


I am looking for [Clues] – So I can hang my – [Miner’s Hardhat] – On -

but I don't have a video camera attached to my pc, or it could be sosmething for my Canon A95 camera, some kind of interface. I really don't hook up my camera to the pc . I will go over your logs and see what additional information I can provide


Include all Instances in [Device Manager] – about this Device – Being that the [Error Message] about Scanner Status is –

"unable to start the scanner because it is not ready or another application is using it"



This is probably – [The Other Application] – Canon A95 Camera – [Device Manager] will show if it was ever connected – Just make sure when you –Open [Device Manager] – You check – [Show Hidden Devices] – each time – and you have to be running in – [Safe Mode] –

The Camera & Scanner are – [Device Cousins] – They belong to the same –[Imaging Device Family] – And they are probably both [Twain Devices] – And probably both USB Interface – And your USB 2.0 Host Controllers are – [VIA] – which has documented – [Anomaly] – when installing and/or running these twain devices –

I am giving you – [Detailed Post] – and I expect – a [Detailed Report back] – not just an answer –

went through your posts and I think I did just about everything you suggested



I need to know – [What you did] – Not – What you think you did – I have a purpose for every statement/question – Even when it seems – [Redundant] – There is a Reason/purpose –
I am a little different than most – Most people have [Questions] that need [Answers] – I have [Answers] that need [Questions] – It is just my – [Dutch Heritage] – So when our – [Answers] – have the same – [Questions] – We are done –

Have a Good Day
Jack123
  • 0

#115
Ardent

Ardent

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 153 posts
Ok I will tell you what I have done. I have been in msconfig made sure that Hide all MS serices is unchecked.

I have also verified that Plug and play is checked. I have made sure all my hidden files an folders are

viewable and that "hide protected OS files is deselected. I gone into device manager to view Non Present

devices. I DO recall doing this but as per your instructions ("1 time process") I have not do it again. I have

attached an Everest report that I did 1/19/06 at 4:10 pst.

The latest on the scanner is that it is still giving me the same messages. THere are no items in device manager in Window but they are there in safe mode. I went to device manager in Safe

mode and saw the epson 1670 driver. I uninstalled it as I plan on a new installation without any virus or

spam software on. When I was there, there wasn't a canon camera under imaging devices as was the

scanner. There was however a canon i560 printer there and it had a yellow circle with and exclamation point

in it. I have had the printer for 8-12 months and have never had a problem with it.

Attached Files


  • 0

Advertisements


#116
Ardent

Ardent

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 153 posts
I have done a reinstall with the the anti virus progam off as well as the anti spyware program. The software installed fine. Then I plugged in the scanner and the "found new hardware wizard" came on. After a long search it said it couldn't find the software.
I tried launching the software and nothing happened 10-20 seconds so i tried it again. It eventually came on about a minute later with the message the the program was busy and I should go to "switch to' because the other program is busy and I should choose switch to to activate the busy program and correct the problem.

Another thing I remember. Back when this started there was a connection to the scanner that worked . I want to say it was a WIE or WEI device. It was listed when I was in another application as such a device in addition to the 1670 scanner. It would start a very rudimentary scanner process and I could get a very low res scan. That whole option went away shortly after I tried renistaling the software the first time ..
  • 0

#117
Jack123

Jack123

    Trusted Tech

  • Retired Staff
  • 944 posts
Scanner Twain Problem (PMW-#4)
19th Jan 2006

Item [1]

I DO recall doing this but as per your instructions ("1 time process") I have not do it again.


That was meant for the [Command Window] Routine – Where you opened [Device Manager] – Using the [Command Window] – But you must check the – [View Hidden Devices] – under [View Tab] – Each time you open [Device Manager] – using Normal Opening Procedure – In order to View [Non Present Devices] – Which are – Identified – by the – Light Gray Print -

Lets try to open [Device Manager] this way -

1- Click [Start Button]
2- Click [Run]
3- Type devmgmt.msc
4- Click [OK]

Did [Device Manager] Open – And are there any [Devices] shown – Or is – [Device Manager] still Empty –

If the Folder is showing Devices - Then Click on [View] Tab & Click -[Show Hidden Devices] - Now do you see the [Non Present Devices] for [Scanner] and/or [Camera/s] and [Other Devices]

Post back results –

Jack123

Edited by Jack123, 19 January 2006 - 09:06 PM.

  • 0

#118
Ardent

Ardent

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 153 posts
The device manager was blank.
  • 0

#119
Swandog46

Swandog46

    Malware Expert

  • Member
  • PipPipPipPip
  • 1,026 posts
  • MVP
If you don't mind my jumping in here.... the fact that you cannot see Device Manager in normal mode, but you CAN in Safe Mode is a strong indicator of the Apropos rootkit. You may have a new variant that the tool did not remove. I am going to ask you please to do the following:

Please download RootKitRevealer from here:
http://www.sysintern...kitrevealer.zip
Unzip it to the desktop, run it, and click Scan. This will generate a log file; please post the entire contents of the log file here for me to see.

Download Registry Search and unzip it to the desktop but do NOT run it yet.

1) Reboot back into Safe Mode (please do not skip this step or this WILL NOT WORK!) :tazz:
2) Go to Start -> Run -> regedit and press Enter.
3) In the Registry Editor, use the left-hand panel to navigate to:

HKEY_LOCAL_MACHINE\Software

4) Underneath the Software key, there will be lots of other keys. You are looking for a strangely-named one with about 16-20 random letters in the name, likely starting with 'C'. If you find this, please right-click on it and choose "Export". Save the export to the desktop as "apropos.reg" or something.

Then close regedit.

5) Double click Registry Search to start it. Enter adchannel in the edit and click "Ok". Notepad will be opened with text in it (the file will be saved in the program's folder as well). Save this text to the desktop.

Then please do the same for the string contextplus, and save this text as well.

Finally, please reboot back into normal mode and please post the contents of all of these files here for me. There should be three in total.

Thank you very much --- this information will help me not only to diagnose your problem, but to help others as well, if I can see what is going on with this infection. :)
  • 0

#120
Jack123

Jack123

    Trusted Tech

  • Retired Staff
  • 944 posts
Scanner Twain Problem (PMW-#5)
20th Jan 2006

Thanks Swandog46 – Pleasure to have you here – Coachwife6 suggested that I look you up in –[Post 110] of this Thread – But did not find you in my – [Search] – Should have used – [Swandog*]

Yes, Jack. We did the appropos rootkit fix several times and it was clean. You might have Swandog look at the last few posts if you want to make sure. I believe he wrote the program.


I have seen a few more of these – [Device Manager Empty Posts] – in various other Forums – that had the same suggestion –

the fact that you cannot see Device Manager in normal mode, but you CAN in Safe Mode is a strong indicator of the Apropos rootkit.


And that did not repair/fix the [Device Manager Problem] either – And they still appear to be unresolved - I will look thru my notes & PM you the – [Threads] –

Of course out of the over 1200 Viewers looking at this Thread – Some of these – [Unresolved Posters] – seeing this Thread – Perhaps you might want to – Post a set of Instructions on how you would like them – To Contact you

Thanks again –
Jack123

Edited by Jack123, 20 January 2006 - 03:14 PM.

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP