Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

PCI device found

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 1 posts
I keep getting a new PCI device found. When I try and find a driver for it, it says can't be found. It show us in the divice manager under other and it has the yellow astrisk by it. I have searched for the device driver in the cds provided for it but no dice. It also searches the internet but same result. When I look under the properties of the device is says locatioin: PCI bus 0, device 31, function 3. I sure would like some help here. Most of the time I an solve these problems.

thanks so much,

Graig :tazz:
  • 0




    Trusted Tech

  • Member
  • PipPipPipPipPipPip
  • 3,476 posts
Welcome to G2G Graig. Apologies for the delay in responding to your topic.

This type of thing of thing doesn't normally happen out of the blue, so can you tell me if anything changed just prior to the system detecting this unknown pci device for the first time?
For example, did you reinstall the operating system, add any new hardware or make any changes to the bios at all?
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP