Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

LAN "unplugged"


  • Please log in to reply

#1
TOm Scott

TOm Scott

    Member

  • Member
  • PipPip
  • 36 posts
Two days a relatively new system that has been flawless looses LAN connection, and idicated the LAN is unplugged. System running 2k, current SP. AMD XP2200, 512MB ram. Onboard ethernet

I check conncetions, then connect a laptop machine to the LAN cord-- works fine.

Plug back into the machine in question, no dice.

Check device manager -- network adapter working fine.

No conflicts

Check driver - fine and current.

Check plug in to be sure there is no "wiggle room". It is tiht.

Check system status - no clnflicts - BUT

there are five and a half devices running on IRQ 11.

IRQ's #2,3,5,5,10 and 16 are available.

Try to reassign the Video Adapter, an the Enhanced Audio Controller - but cannot do it. There appears to be no capbility to do that in device manager as pe window istructions.

Am I approaching this wrongheaded. or what?

Thanks in advance :tazz:
  • 0

Advertisements


#2
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
any reason why the nic just couldn't be defective?

Insert a different nic, repeat to see if errro recurs
  • 0

#3
TOm Scott

TOm Scott

    Member

  • Topic Starter
  • Member
  • PipPip
  • 36 posts
It is possible that the NIC has gone bad. As it is "onboard" I cannot remove it, but can uninstallit and insert a PCI card, which I will do later today.
  • 0

#4
mcpscomp

mcpscomp

    Retired Staff

  • Retired Staff
  • 180 posts
I think your problem is here:

" Check plug in to be sure there is no "wiggle room". It is tiht."

What type of cable you use? The good combination usually not that tigh as you you said. Remember years back I had this problem on one of my P2. It took me weeks to find out that it was my self made cable. It work with every other machines but that one. Finally I too found out that it was too tigh and all the contactors being pushed out of place where they were supposed tobe.... and ofcouse the contacts are not made.
  • 0

#5
estople

estople

    Member

  • Member
  • PipPip
  • 16 posts
mcpscomp is right, typically this is an indication that you've got a low signal level. This could be due to a lot of things, like poor connections, cable too long, etc. If you're running at 100 Mbit, try forcing the connection to 10 Mbit and see if the problem goes away. (10 Mbit connections are a lot more forgiving on signal strength.)

This presupposes that your hardware will support the lower speed, of course (some 3Com NICs will only run at 100 Mbit), but most do, even on-boards like you have. To find out, select Start, Settings, Control Panel, then select System, Device Manager, and expand the Network Adapters tree. Right click on your NIC name and select Properties. You don't say what your NIC type is, so from here you're going to have to play around a bit, but there should be an "Advanced" tab that allows you to select the "Media Type" or some such. Something like "100BaseTX-Full Duplex" should be selected, pick "10BaseT-Full Duplex" or something similar. Click "Apply" and/or "OK", close everything, cold boot (some NICs won't switch speeds until the system restarts) and see if the network is happy.

This happened to me when I added my digital phone TA. The signal coming out of it wasn't as strong as the one from my cable MODEM and couldn't effectively drive the 25 foot cable. Since my Internet connection is only 5 Mbit, I left the NIC set at 10 Mbit. If you have a need for a faster speed, this will only act as an indicator of low signal strength, and you should look to the places the mcpscomp has suggested.
  • 0

#6
TOm Scott

TOm Scott

    Member

  • Topic Starter
  • Member
  • PipPip
  • 36 posts
Thanks to all,

Unfortunately I cannot report a resolution.

Try as I may, I am unable to istall an alternitive NIC. While I can install it on the board and the software as well, the board always defaults to the "onboard" NIC and will no allow the Linksys card to "start" (that is the error message given)

As for the "poor signal" thinking, this point is located approx 12 feet from the router, as the crow lies. The line has been functional for more that 5 years with no problems in signal strength.

Just to make myself more confident, I did change out the patch cable between the wall connector and the machine, to see if that made any difference. It made no difference as the laptop continued to function properly and the desktop continued to insist that the LAN cable is unplugged"

I have other machines that are located over 40 feet from the router with no issues.

In fact, this machine ran just fine for about 6 weeks, until wednesday of this week.

No indication of possible problem. Just quit.


I can report the following, and in doing so can tell you that I cannot change anything in this regard:

during BOOT sequence the IRQ's are shown as; RAID 11, USB 11, AGP Video 10, NIC 10,

System information, after the boot, shows the following and seems to idicate conflicts / sharing on IRQ, yet non of the devices indicate conflict All of he following are shown on IRQ 11:

AGP Video, RAID, NIC, USB, Enhanced Audio.

In all respects excepting this, the machine runs very very well.

Thank you
  • 0

#7
estople

estople

    Member

  • Member
  • PipPip
  • 16 posts
The on-board NIC can be disabled through the BIOS. During the boot sequence, you'll see something like "Press Del to enter Setup." Once in the setup screen, go to the menu that allows you to manage the built-in hardware like the USB and other ports. From there, you can set the on-board NIC to DISABLED. This will allow the Linksys NIC to start. (Linksys is good in this instance; you can set the speed on all of them and I know how! :tazz: )

You can also move the IRQs around there as well, including the one for the AGP slot/built-in adapter, and the USB. Don't do this now, though, let's solve one problem at a time.

Am I right in assuming that the network is operating with the on-board NIC and that we're just trying to get rid of the annoying little systray alert?
  • 0

#8
TOm Scott

TOm Scott

    Member

  • Topic Starter
  • Member
  • PipPip
  • 36 posts
estople -

Your assumption is incorrect. If the onboard NIC was operational, I would not be taking up your valuable tiem. It is not, for what seems to me to be a faulty onboard connector. That is the reason that I am attempting to "get around it".

It is also possible that the huge number of devices sharing IRQ is making it impossible fot the onboard NIC to operate - I am simply tossing out a guess- and if I could re0distribut the IRQ's maybe things would improve.

I will investigate your points with regard to BIOS and report back late today.

Thank you
  • 0

#9
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts
Winxp does a good job of sharing IRQs, so I am less concerned about that, particularly if the devices are all onboard

Disable the onboard NIC, by looking for Onboard LAN enable/disable

That said, you should be able to add multiple nic cards (this is known as a multihomed machine.

The error you mentioned on the onboard Lynksys to start...where is the error? Event viewer? Can you amplify...I suspect they are related

WinXP Home or Pro?
  • 0

#10
TOm Scott

TOm Scott

    Member

  • Topic Starter
  • Member
  • PipPip
  • 36 posts
My initial post about WinXP was in error, and I think I correct that in the subsequent post. The machine is Win2k, SP4.

Does any of that matter?
  • 0

Advertisements


#11
mcpscomp

mcpscomp

    Retired Staff

  • Retired Staff
  • 180 posts
You may think I'm crazy but again check your conectors. To be more exact, just how it fit together right at the back of your machine. It supposed to fit together easy with a click at the end of it. If there is no wigling, there is problem.
  • 0

#12
TOm Scott

TOm Scott

    Member

  • Topic Starter
  • Member
  • PipPip
  • 36 posts
Don't think you are crazy at all. In fact, I have checked that aspect several times over the past days.

Here is what I have done today, and, as a result, I am thinking strange thoughts.

I got into BIOS, turned off the "onboard" NIC.

I have installed a Realtek MIC

I have installed a Macrosonix NIC

Both installed without issue. Both indicate "Netwoek cable unplugged"

I brough up the Apple ibook again, plugged it into the same cable that I have been plugging into this machine.

The Apple laptop accesses the internet without issue.

Immediately plug the network cable into the desktop machine - NOTHING!!!

There is no peace for Charlie Brown!!!!!

Is there a switch within win2k that I am missing??? I don't know of one.
  • 0

#13
mcpscomp

mcpscomp

    Retired Staff

  • Retired Staff
  • 180 posts
I ran 2K long time ago and I dont think there is a switch or any thing. In my experience, 2K actualy better in networking. One more thing that make me think I'm on the money is Windows only give you that message when the it physically unpluged. Not much I can say now since you already check your cable but if I was you I will push, pull, wigle..... that cable 'till I find the lose, the tigh, the broke point of it.
Anyway I will follow your post 'till you or some body find out what it is. Please don't give up since life don't have much of the good challenge to offer.

Edited by mcpscomp, 22 January 2006 - 05:47 PM.

  • 0

#14
gerryf

gerryf

    Retired Staff

  • Retired Staff
  • 11,365 posts

My initial post about WinXP was in error, and I think I correct that in the subsequent post. The machine is Win2k, SP4.

Does any of that matter?



Whoa, missed that completely and it might matter. Win2k is not quite as good at sharing IRQs...that said, Win2k was also less adept at picking up transmission rates


Right click the Network Neighborhood Icon choose PROPERTIES, choose your LAN connection, choose PROPERTIES (again), choose the CONFIGURE button on the NIC adapter, then go to advanced.

Look for CONNECTION TYPE. If it is AUTOSENSE, change it to the appropriate connection type for your connection.

Actually, set to 10baset half-duplex first and then test. (this is the default for a hub). If that works, experiment with the other choices.
  • 0

#15
mcpscomp

mcpscomp

    Retired Staff

  • Retired Staff
  • 180 posts
Hey Tom
Any news yet?
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP