Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

Problem with HTM and HTML file icons


  • Please log in to reply

#1
CelestialTeardrop

CelestialTeardrop

    Member

  • Member
  • PipPipPip
  • 262 posts
I also posted this on the Internet boards, not sure where the best place to put it would be.

I downloaded IconPackager some time ago to see what it had to offer, but did not use it even once to change any of my icons or settings, whatsoever, as I didn't like what I saw all that much. Since I didn't plan on using it I uninstalled it.

Turns out that uninstalling IconPackager resets all icons (including those for file extensions under Folder Options) and pointers back to defaults. :tazz: :) The actual program the the file type opens with did not change, just the icon representing the type of file.

I went back and changed each icon representing a file type manually (wordpad back to MS Word, etc). Everything could be changed back, except the icons for HTM and HTML files. When I click on either HTM or HTML is says "opens with: Firefox" and in "advanced" I used the "change icon" to bring back the firefox icon. Although it shows up in the preview, the icons representing HTM/HTML files on my computer are still those of Internet Explorer.

Does anyone know how I can change the icons back to those of Firefox?

Thanks in advance.
  • 0

Advertisements


#2
wannabe1

wannabe1

    Tech Staff

  • Technician
  • 16,645 posts
CelestialTeardrop...

Have you set Firefox as the default browser? If not, doing so should change the icons to the Firefox icon.

wannabe1
  • 0

#3
CelestialTeardrop

CelestialTeardrop

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 262 posts
Yes, I have Firefox set as the default browser.

In Folder Options, under details for both HTM and HTML files it says "Opens with: firefox". Everything works as it should (as far as I can tell), except for the wrong icon representing html and htm files (IE even though it is set to use the firefox icon).
  • 0

#4
wannabe1

wannabe1

    Tech Staff

  • Technician
  • 16,645 posts
CelestialTeardrop...

Humor me for a minute....

Open Firefox, click "Tools" on the toolbar, and select "Options". Click on the "General" icon and, in the "Default Browser" box, click the "Check Now" button. If Firefox is not registered as the default browser, set it as such. Then try changing the icons for HTM and HTML in Folder Options.

If this does not help, uninstall and reinstall Firefox...that should set the file associations if you set it as default browser during the installation.

wannabe1
  • 0

#5
CelestialTeardrop

CelestialTeardrop

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 262 posts
I checked if firefox was the default through Tools -> Options -> General -> Check Now (under default browser) about an hour ago, and firefox was indeed the default.

As for reinstalling firefox: A few days ago I updated to version 1.5 but didn't like it, so I did a clean install of my previous version of firefox (1.0.7), meaning that all the firefox files on my machine were deleted and installed anew. However, the problem of the icons still remains. :tazz: It's all very mysterious, almost as if uninstalling IconPackager locked the html and htm icons on Internet Explorer.

Thanks for your help and suggestions.

Edited by CelestialTeardrop, 03 February 2006 - 09:47 PM.

  • 0

#6
CelestialTeardrop

CelestialTeardrop

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 262 posts
Found the solution!

IconPackager must have altered the registry. :tazz:

In the registry editor, in HKEY_CLASSES_ROOT\CLSID\{42042206-2D85-11D3-8CFF-005004838597} under Old Icon there are folders for FirefoxHTML and htmlfile. If you look in the default icon subfolder under each of them, it gives the path to the icon used in each instance.

Under FirefoxHTML the path for the icon should be C:\PROGRA~1\MOZILL~1\FIREFOX.EXE,1. The icon was showing up as the one for IE because the path there was C:\Program Files\Internet Explorer\iexplore.exe,1 (this path is the one that should be in the default icon folder for htmlfile not FirefoxHTML).

Changing the path in FirefoxHTML\Default Icon to C:\PROGRA~1\MOZILL~1\FIREFOX.EXE,1 fixes the problem.

:)

Edited by CelestialTeardrop, 04 February 2006 - 01:45 PM.

  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP