Jump to content

Welcome to Geeks to Go - Register now for FREE

Need help with your computer or device? Want to learn new tech skills? You're in the right place!
Geeks to Go is a friendly community of tech experts who can solve any problem you have. Just create a free account and post your question. Our volunteers will reply quickly and guide you through the steps. Don't let tech troubles stop you. Join Geeks to Go now and get the support you need!

How it Works Create Account

Strange Behavior Opening Programs in Win7

  • Please log in to reply




  • Member
  • PipPip
  • 61 posts
Lately there's been something odd happening in my new Windows 7 PC. Sometimes when I click on one of my browser icons in the taskbar (either Firefox or Chrome) nothing happens. I have the Aero themed taskbar so when I click these icons I can see they highlight and then a small rotating disc appears (I take it this is Win7's equivalent of the old hourglass symbol), but then nothing opens. However, once in a while (when this odd behavior happens) the browsers will sometimes open long after I've clicked their icons, which is really strange.

This happens with most programs I click on right after starting up my computer - like ThunderBird, Everest, etc. I'm not sure if maybe it's something caused by ZoneAlarm - it usually takes ZA and avastHome a bit to load after I reach the desktop. I have all these programs set as "allowed" in ZA so I know it isn't that. I scan my computer for viruses and malware/spyware on a daily basis and nothing has been reported. I'm not sure what's going on, but it seems rather odd behavior for a newly installed OS. If anyone can help me with this I would sure appreciate it.

Thank you.
  • 0




    Kraków my love :)

  • Member
  • PipPipPipPipPipPipPipPip
  • 12,300 posts
Go Start>Run (Start Search in Vista), type in:
Click OK (hit Enter in Vista).

Click on Startup tab.
Click Disable all
IMPORTANT! In case of laptop, make sure, you do NOT disable any keyboard, or touchpad entries.

Click Services tab.
Put checkmark in Hide all Microsoft services
Click Disable all.

Click OK.
Restart computer in Normal Mode.

NOTE. If you use different firewall, than Windows firewall, turn Windows firewall on, just for this test, since your regular firewall won't be running.
If you use Windows firewall, you're fine.

Same problem?
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP