Jump to content

Welcome to Geeks to Go - Register now for FREE

Need help with your computer or device? Want to learn new tech skills? You're in the right place!
Geeks to Go is a friendly community of tech experts who can solve any problem you have. Just create a free account and post your question. Our volunteers will reply quickly and guide you through the steps. Don't let tech troubles stop you. Join Geeks to Go now and get the support you need!

How it Works Create Account

Windows 7 blocking ports.

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 3 posts
I am currently having a issue about hosting in Wc3. Maybe one of you can help me in solving this issue. I doubt it... I have tried everything.. but, if you think you have the answer.. then keep reading:

I am still unable to host in warcraft III. I have full acceses to wc3, however, no one can join the custom games I try to host.

I have the following:
-2wire router, linksys router, or a dsl modem that has no need in portforwarding. (I have currently tried hosting with the provided, no luck)
-Windows 7
-Avast -free edition- ofc(normaly running) , SUPERAntispyware Free edition(normaly off), Malwarebytes' Anti-Maleware(normally off), Windows Defender(normally running), and a common Windows Firewall (normally on).

I have tried the following:
-All of the routers listed in DMZ mode/ forwarded proper ports. I have contacted my intetnet service provider to double check my port forwarding (recommended by blizzard... ofc lol), also followed the popular site http://www.portforwarding.com. I have also tried a old modem I used before (years ago when I was able to host with it. Note:I did not have windows 7 at that time). I tried another dsl modem by itself (that my family member uses with her linksys router. I unplugged the router just to use the modem. I also tried forwarding correctly the linksys router).
-I have tried completely turning off (aswell as adding exceptions) avast,SUPERspyware,Malewarebytse, windows firewall, and windows defender.
-The ports I forwarded was tcp and udp 6112-6119.. I recently found out that you only have to forward tcp 6112-6119.. not udp.. but this shouldnt of mattered b/c I tried DMZ mode and 2 modems ( one old modem that I hosted with b/f as I already told you)

I ran out of ideas on how to make my computer as open and as vulnerable as I possibly can. I turned every software I can think of off and tried dmz modes /portforwarding/ using modems. The only thing I can think of is...

1. It has something to do with windows 7, such as.. another antivirus software or some kind of protection software that came with windows 7 that I do not know about. That runs hiden in the background.
2. Something was changed about wc3, doubt it.. I wouldnt know, It has been a while sinse I played wc3.
3. Maybe I need to reinstall the game?

One more thing.. during my many trys and fails.. I would test if my port was open with this website >http://www.whatsmyip.../port-scanner/< (I also tested by hosting In-game aswell just in case the website was false) Now, I was told it was reliable.. but you know how that stuff goes. Anyways, during my many port scanning.. I would 9/10 get a reply of " Timed-Out " when I would test 6112 port. When I called Blizzard (Company that made wc3 fyi) they told me that Timed-out is caused by a software program preventing traffic passing through (Note: why I turned all the protection software / any software of that matter that I knew about off during my testing).

If you have any idea, same issue / fixed it , or seen something I did not try.. please tell me..

  • 0




    Tech Moderator

  • Retired Staff
  • 9,285 posts
try posting in the games forum here...you should be able to get help there... :thumbsup:
  • 0

Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP