Jump to content

Welcome to Geeks to Go - Register now for FREE

Need help with your computer or device? Want to learn new tech skills? You're in the right place!
Geeks to Go is a friendly community of tech experts who can solve any problem you have. Just create a free account and post your question. Our volunteers will reply quickly and guide you through the steps. Don't let tech troubles stop you. Join Geeks to Go now and get the support you need!

How it Works Create Account

Black Screen with Cursor, No Windows Utilities Work, xPud Works

  • Please log in to reply



    New Member

  • Member
  • Pip
  • 4 posts
Hello all. I have a Toshiba Satellite A665-6070 with Windows 7. About 2 months ago it was damaged while being checked in airline baggage. It appeared that the screen was smashed so I took it to a big box chain vendor for an estimate. They sent the laptop to their repair facility and quoted me over $300.

I decided I could do the work myself and asked them to send it back. When I got the laptop back, I went to go retrieve some files off of it. It booted fine but then locked up once the Windows desktop loaded. I did a hard reboot and when it booted up it gave me:

"Windows failed to start. A recent hardware or software change might be the cause"

"Launch Startup Repair (Recommended)"
"Start Windows Normally"

Start Windows Normally would not work. It would just flash and reboot. So I finally did the Launch Startup Repair and it eventually loaded up after going through hours of self test.

So I got the files I wanted off and ordered a replacement LCD screen. When the screen arrived I did the appropriate hardware replacement and started up the laptop. Again, initially it booted up Windows and loaded the desktop, but then locked up. However, every time I reboot the machine I still get the same options as before, but NOTHING works. Startup Repair, Safe Mode, Recovery Disk, Win Rec Env 64 bit, and a USB stick with Windows PE all end up with a black screen with a white cursor.

I found a post on this site (http://www.geekstogo...linking-cursor/) that seemed similar to my problem so I followed it's procedures. I was able to load xPud on the laptop and copy over the MBR. I then scanned the MBR on another computer with Avast AntiVirus and found no problems. I went ahead and did the MBR fix suggested in the thread and still no luck.

I'm not sure if the laptop is infected or just corrupted. I am willing to wipe the hard drive and start from scratch, but I can't get anything Windows to load.

Thank you for any help at all. I'm at my whits end.
  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP