Jump to content

Welcome to Geeks to Go - Register now for FREE

Need help with your computer or device? Want to learn new tech skills? You're in the right place!
Geeks to Go is a friendly community of tech experts who can solve any problem you have. Just create a free account and post your question. Our volunteers will reply quickly and guide you through the steps. Don't let tech troubles stop you. Join Geeks to Go now and get the support you need!

How it Works Create Account
Photo

Windows 8.1 suddenly lagging and slow


Best Answer phillpower2 , 15 April 2015 - 10:54 AM

I make a point of never calling a notebook computer a laptop as it implies that one should be used sat in your lap when the fact is that one should not be   Notebook computers require coo... Go to the full post »


  • Please log in to reply

#31
pjgoodman2

pjgoodman2

    Member

  • Topic Starter
  • Member
  • PipPip
  • 64 posts

First of all, I totally agree with @phillpower's findings thus far.  I've damaged a laptop CPU due to lack of airflow, but didn't know it until some time later after reduced performance.  Heat damage is permanent, but fortunately today's CPUs have thermal throttling built-in, which is intended to prevent damage. 

 

If it's only happening in Chrome, have you tried running Chrome with different plugins disabled?  This page has more information.  Also try Incognito Mode, which disables extensions for the browsing session.

 

Does it happen in Internet Explorer?  Firefox?  If so, I think it points more at the wireless hardware and software on this particular machine.  If not, then you might try resetting Chrome.

 

I don't want to keep dragging the thread out here (sorry phillpower2).  @pjgoodman2, are you getting page redirects, or pop-up advertising, or other symptoms of malware?  If so, we can re-open your malware thread, but it honestly doesn't sound like that is the case.

 

Good luck!

 

  DanoNH,

 

  It happens in Chrome, Firefox and IE. I have tried Chrome in Incognito mode and it is the same. And no, no page redirects or pop ups. Nothing to make me suspect another infection. I guess it's time to take it to a shop in case it is the CPU.

 

  Thanks for all the help, both of you.


  • 0

Advertisements


#32
DanoNH

DanoNH

    Trusted Helper

  • Malware Removal
  • 2,155 posts

You are most welcome. :)


  • 0

#33
phillpower2

phillpower2

    Mechanised Mod

  • Global Moderator
  • 24,747 posts

Apologies for the late reply folks been rather busy with work atm  :(

 

Thanks for the additional support DanoNH  :thumbsup:

 

To see if this is directly related to the notebooks wireless card can you try disconnecting the wireless router and plugging an ethernet cable into the notebook to see if the internet performance is still the same.

 

You are both welcome btw  :)


  • 1

#34
pjgoodman2

pjgoodman2

    Member

  • Topic Starter
  • Member
  • PipPip
  • 64 posts

Apologies for the late reply folks been rather busy with work atm  :(

 

Thanks for the additional support DanoNH  :thumbsup:

 

To see if this is directly related to the notebooks wireless card can you try disconnecting the wireless router and plugging an ethernet cable into the notebook to see if the internet performance is still the same.

 

You are both welcome btw  :)

 

  Phillpower2,

 

  Will try this after work today. Still having the problems with it......


  • 0

#35
phillpower2

phillpower2

    Mechanised Mod

  • Global Moderator
  • 24,747 posts

:thumbsup:


  • 0

#36
phillpower2

phillpower2

    Mechanised Mod

  • Global Moderator
  • 24,747 posts

Not heard back from you pjgoodman2, do you still require assistance or is the issue now resolved, an update would be appreciated.


  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP