Jump to content

Welcome to Geeks to Go - Register now for FREE

Need help with your computer or device? Want to learn new tech skills? You're in the right place!
Geeks to Go is a friendly community of tech experts who can solve any problem you have. Just create a free account and post your question. Our volunteers will reply quickly and guide you through the steps. Don't let tech troubles stop you. Join Geeks to Go now and get the support you need!

How it Works Create Account

Packard bell - windows 10 error

- - - - -

  • Please log in to reply

Renzo JacQuez

Renzo JacQuez

    New Member

  • Member
  • Pip
  • 1 posts
I have a office computer (packard bell imedia s2883)
I was reseting/formatting it. And it was about 2% completed when i accidentally cut the power and from there it won't start no more.
When i push the power button it just show the packard bell logo and turn off. It keeps doing it until i turn it off completely.
I tried everything i have a windows 10 on my usb but the computer wont read it.
I went to click alt+f10 and tried everything there but still nothing.
I even used prompt command i search everything but still nothing.
Please help.
Hers a video of my computer

Edited by Renzo JacQuez, 04 June 2016 - 03:57 AM.

  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP