Jump to content

Welcome to Geeks to Go - Register now for FREE

Need help with your computer or device? Want to learn new tech skills? You're in the right place!
Geeks to Go is a friendly community of tech experts who can solve any problem you have. Just create a free account and post your question. Our volunteers will reply quickly and guide you through the steps. Don't let tech troubles stop you. Join Geeks to Go now and get the support you need!

How it Works Create Account

Seagate Backup Drive Problem

- - - - -

  • Please log in to reply




  • Member
  • PipPipPip
  • 240 posts

Hi, I bought a Seagate Backup 8TB hub in July and have had nothing but trouble with it ever since.


To begin with it was not recognised by my system. When it eventually was, by randomly trying different USB ports, I presumed it was OK. After some weeks thinking it was working and mirroring one of my partitions on another drive, I noticed in ‘This PC’ that it was not showing; nor in ‘Disk Management’.


In ‘Device Manager’ I saw the top USB Host Controller had the yellow exclamation mark over it and its ‘properties’ showed ‘Code 43’. I searched on line for an answer without success and contacted Seagate who took some time to respond and suggested things I had already tried. They then decided the drive may have a fault and replaced it.


Unfortunately, when I received the new drive, I had the same problem. I then presumed it was my system, although other smaller, non ‘Seagate’ backup drives where immediately recognised.

At this point I had not connected the drive to another system but when I did it ‘was’ picked up.


I still get the 'code 43' on my main system (which is up to date) and yet the drive ‘is’ picked up in what seems to be a random manner more often in a USB 2 port rather than 3. In my searching I found that it is a known issue with these drives.


Seagate now say they cannot solve the issue and just suggest that I format it. I intend to do a full format and started to do so but with a USB 2 port having recognised it I saw from the speed it was working it would take a few days, so I will probably do that on another PC.


Has anyone got an idea what the problem might be? As I said I have tried several things but I am willing to try again if anyone thinks they can help. Any other info needed just ask. Thanks.


  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP