Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works

Need Help: ImageMixer3 and Hitachi Camcorder

  • Please log in to reply




  • Member
  • PipPip
  • 37 posts
Hey everyone.

PC: Dell
OS: Windows XP Media Edition with SP2
Camcorder: Hitachi DZ-HS300A

Last weekend, we bought a Digital Camcorder. It has MiniDVD and a built-in 8gb HD. It uses a USB 2.0 cable to transfer video from the built-in HD to the PC. It came with ImageMixer3.0 as its software. The camcorder is awesome and we love it.


We can go through the entire process of capturing and editting the video from the camcorder. But when we go to save the video file, we get this error:
Posted Image

There are no further details on the error.

I have tried everything I can think of to overcome or bypass this. I have reinstalled several times, removed all codecs, run multiple virus programs, tried it on a whole other computer (same exact results), tried different USB ports, and even tried completely different software.

I have no problem using a different software as long as I can get the video off the camcorder. When I use Ulean VideoStudio 11 or MS Movie Maker, neither recognize the device to capture from. I am assuming this is b/c it's not connected with firewire like most are (and the camcorder doesn't even have firewire).

Any help would me greatly appreciated.

  • 0


Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP