Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

How to make files write as well as read?


  • Please log in to reply

#1
Wol

Wol

    Member

  • Member
  • PipPipPip
  • 101 posts
Windows Seven: HP desktop with C Drive internal plus two USB hard drives external.

I cannot edit images that are on the external drives: the program says "Error writing to file" or "Access denied". Looking at the Images folder, I saw it had the "Read only" attribute - so I changed that to "Read and write".

Tried again - same error message. Looking at the attributes for the folder again - it was back to "Read only"!

Another W Seven "feature"?
  • 0

Advertisements


#2
phillipcorcoran

phillipcorcoran

    Member 1K

  • Member
  • PipPipPipPip
  • 1,293 posts
No - it's not another Windows 7 'feature'. That particular misunderstanding of Windows folder attributes has existed for several years. A folder cannot be "read only". That attribute only applies to files. If you look carefully at the properties page for a folder, the 'read only' tick-box always defaults to a solid box which means that setting cannot be applied to a folder, it's an irrelevant setting as far as folders are concerned.

You will need to 'untick' the read-only attribute for each file you wish to edit, or create a file with a different name after editing it.
  • 0

#3
Wol

Wol

    Member

  • Topic Starter
  • Member
  • PipPipPip
  • 101 posts

No - it's not another Windows 7 'feature'. That particular misunderstanding of Windows folder attributes has existed for several years. A folder cannot be "read only". That attribute only applies to files. If you look carefully at the properties page for a folder, the 'read only' tick-box always defaults to a solid box which means that setting cannot be applied to a folder, it's an irrelevant setting as far as folders are concerned.

You will need to 'untick' the read-only attribute for each file you wish to edit, or create a file with a different name after editing it.


Thanks for that. Perhaps you can answer another similar question: I much prefer to show "Details" in all my folders rather than the icons or tiles. I can't seem to make the system show details for every folder - I have to set each one individually. And even then they often change back to icons when my back's turned! I seem to remember that in XP you selected "details" in the control panel and it set this for every folder and file but it doesn't seem to do it in Seven?
  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP