Jump to content

Welcome to Geeks to Go - Register now for FREE

Geeks To Go is a helpful hub, where thousands of volunteer geeks quickly serve friendly answers and support. Check out the forums and get free advice from the experts. Register now to gain access to all of our features, it's FREE and only takes one minute. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.

Create Account How it Works
Photo

LENOVO IDEACENTRE A340-22IWL M2 UPGRADE (PART 2)


  • Please log in to reply

#1
JoMalig

JoMalig

    Member

  • Member
  • PipPip
  • 45 posts

Hi,

 

Previously, I upgraded my 2 out of 3 Lenovo Ideacentre A340-22iwl all in one desktop computer from HDD to M2.

These 2 are working fine and running smoothly. I put Crucial P5 250 GB CT250P5SSD8 Internal Solid State Drive-up to 3400 MB/s (3D NAND, NVMe, PCIe, M.2, 2280SS).

So, after 1 year, I decided to upgrade the 3rd computer and I installed Crucial P5 Plus 500GB M.2 PCIe Gen4 NVMe Internal Gaming SSD - Up to 6600MB/s - CT500P5PSSD8.

As per the crucial system scanner, its showing its compatible.

Now I have problem installing Windows 10 to it.

Using Boot mode Legacy only its showing this error;

LEGACY ONLY.jpeg

ERROR MSG.jpeg

 

How to solve this?

 

When I use Boot mode UEFI only, it wont start with my bootable USB drive (My usb windows installer)

 

BOOT OPTION UEFI.jpeg

 

If I put Boot mode Legacy only it will boot on my usb drive

BOOT OPTION LEGACY.jpeg

 

But then again, if I selected Legacy, I will end up with the error showing on the 2nd screen shot.

 

Please help.

 

Thanks


  • 0

Advertisements


#2
RKinner

RKinner

    Malware Expert

  • Expert
  • 24,425 posts
  • MVP

Your USB drive was formatted with an MBR so is Legacy.  Doesn't your PC BIOS have an option for AUTO?  This would would boot either Legacy or UEFI and is the recommended setting.  

 

Your error is often caused by 1.  Too many hard drives  Try unplugging the extra drives.  2.  Bad drive.  Since you have Windows installed on one drive, boot to that drive and use Disk Management (shows as  Create and Format Hard drive partitions when Search finds it).  In the bottom window find your M.2.  Right click on the Disk (not on the volume.)  Ideally you want this drive GPT but since you already have two working I would compare the working units and make this one look the same.  

 

There should be an option Convert to GPT.  If it's gray then the drive is already GPT (UEFI).  If not gray then you can click on it and change it.  

Now look in the Volume box to the right of the Disk box and it should say NTFS.  If not right click on the Volume box and Format (choose NTFS) and make sure that works.  Windows will normally format a blank drive for you but this way you are sure that it works.  

 

3.  Too low in the boot order.  (Won't be a problem if you remove other drives first.


  • 1

#3
JoMalig

JoMalig

    Member

  • Topic Starter
  • Member
  • PipPip
  • 45 posts

Your USB drive was formatted with an MBR so is Legacy.  Doesn't your PC BIOS have an option for AUTO?  This would would boot either Legacy or UEFI and is the recommended setting.  

 

 

This one solved my problem. I made a Bootable USB drive in GPT format. Then I converted my M2 which is in MBR format to GPT.

 

Thanks alot.

:yeah:


  • 0






Similar Topics

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP