Jump to content

Welcome to Geeks to Go - Register now for FREE

Need help with your computer or device? Want to learn new tech skills? You're in the right place!
Geeks to Go is a friendly community of tech experts who can solve any problem you have. Just create a free account and post your question. Our volunteers will reply quickly and guide you through the steps. Don't let tech troubles stop you. Join Geeks to Go now and get the support you need!

How it Works Create Account

Synaptics driver missing - unable to reinstall

Synaptics touchpad Windows 10 HP Spectre Drivers Missing DLL

  • Please log in to reply

Diane B.

Diane B.

    New Member

  • Member
  • Pip
  • 1 posts

Hi, I'm trying to fix a problem with my synaptics driver and I can't really find any information through Google searches on this problem. I hope someone here may have some advice or ideas!


I have an HP Spectre running Windows 10. I turned on the computer and the Synaptics touchpad options (under mouse settings/an icon in the task bar) were missing. The driver is also missing under "device management" (I have it set to show hidden devices).


Under the control panel there is something that says "Synaptics ClickPad" which is missing the normal Synaptics icon next to it (just this little white page icon). When I click on it this is the message I get:

"There was a problem starting C:\Program Files\Synaptics\SynTP\SynTPCpl.dll. The specified module could not be found."


The file was indeed missing.


I went onto the Synaptics website and downloaded the software/driver for Windows 10. I unziped the download, and ran "setup.exe" it went through the agreement stuff and installed, the next window said the drivers for the touchpad had been correctly installed. Nothing else to click on besides the close button on that window. So, I close it. Nothing has changed. It also never asked where to install and didn't install anything in program files.


I tried copying and pasting the files under the unziped folder in downloads (I doubted it would work, but figured what the hey) to the Synaptics/SynTP folder under program files. This did not help so I just deleted everything. Also, when I copied the files over, the one the ClickPad under control panel complained about was still missing, it wasn't even in the downloaded files. I tried installing again, but same thing happened - says it installed stuff, nothing has changed.


Also, I tried unzipping the file to program files and it really didn't like that. Gave me some program/software errors and said it couldn't be properly unzipped.


Any ideas what is going on here? Not really sure what to try next since the normal uninstalling/reinstalling drivers and software to fix a problem seem to be completely ineffective. Thanks!

Edited by Diane B., 13 December 2016 - 03:17 PM.

  • 0




    New Member

  • Member
  • Pip
  • 3 posts

My suggestion is to uninstall the driver.  If it refuses to uninstall, you will have to install a 3rd party program uninstaller - revo comes to mind, but choose any uninstaller and do a force uninstall. and then reinstall, your problem should be solved.

  • 0

Similar Topics

Also tagged with one or more of these keywords: Synaptics, touchpad, Windows 10, HP Spectre, Drivers, Missing DLL

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

As Featured On:

Microsoft Yahoo BBC MSN PC Magazine Washington Post HP